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What is SPRY Mosaic?

SPRY Mosaic is a browser program that allows you to access the Internet World Wide Web.

Features
• Read information, view pictures and video, and play sounds and music.

• Organize favorite Web pages into hotlists (lists of your favorite Web pages), including folders and 
subfolders, and add selected hotlists to your Mosaic menu.

• Access previously viewed Web pages.

• Read and post news, send mail, and access FTP and Gopher sites.

• Drag and drop Web pages and images to other applications.

• View inline GIF and JPEG graphics.



Understanding the World Wide Web

The World Wide Web provides a variety of rich multimedia information in a    graphical, easy-to-use format.

When people talk about the World Wide Web, they are principally referring to HTML documents located on 
Internet servers around the world.    These documents, referred to as Web pages, include text, images, and 
multimedia files, as well as hyperlinks that jump to other Web pages and Internet sites.    

In addition to Web pages, the World Wide Web also includes FTP sites, Gopher sites, news servers, and more.    



Understanding URLs

A URL (Uniform Resource Locator) provides the address, or location, for a resource on the Internet.    URLs can 
describe many different types of resources, including HTTP sites, FTP sites, Telnet sites, Gopher sites, and more.  
You can use URLs to access any of these resources from Mosaic.

You can supply a URL in the Web Page box found beneath the Mosaic toolbar, or in the Open URL dialog box 
accessed by clicking Open on the File menu.

To access Type Examples (fictitious)

A Web page http://hostname/pathname

where hostname is the IP address 
of the Web page, and pathname 
(optional) describes the exact 
pathname of the page.

http://www.federation.gov/Enterprise

http://www.bakerstreet.com/cases.html

http://165.121.6.240

An anonymous 
FTP server

ftp://hostname

where hostname is the IP address 
of the FTP site.

ftp://ftp.circe.com

ftp://165.121.6.45

A local HTML 
file

file:///pathname

where pathname indicates the full 
path of the HTML file.

file:///c:\html\mypage.htm

file:///f:\tech\tequila.htm

A Telnet server telnet://hostname

where hostname is the IP address 
of the telnet site.    Port information 
can be provided by adding a colon 
followed by the port number (for 
example, :23).

telnet://odysseus.circe.com

telnet://165.121.6.220

telnet://165.121.6.6:23

A Gopher 
Server

gopher://hostname

where hostname is the IP address 
of the telnet site.    Port information 
can be provided by adding a colon 
followed by the port number (for 
example, :70).

gopher://gopher.narnia.com

gopher://gopher.gardenia.com

gopher://gopher.louvre.com:70/art

A USENET 
newsgroup

news:newsgroupname

where newsgroupname is the name
of the newsgroup you want to 
access.

news:alt.tv.seinfeld

More information on using URLs for FTP, Gopher, Mail, and News can be found by clicking Using FTP, Gopher, 
News, and Mail.



The SPRY Mosaic window

SPRY Mosaic's main window appears below. Click the screen to get information about any element shown.



Mosaic’s shortcut menus

Mosaic includes two special menus that you can access using your right mouse 
button. Click the images below to get information about the items on each menu. 

Hyperlink menu
The Hyperlink menu appears 
when you click the right mouse 
button on a hyperlink. The menu 
items will vary according to the 
type of hyperlink you have 
highlighted.

Quick menu
If you click on something 
other than a hyperlink, the 
Quick menu appears.

Search button
Loads a Web page designed to let you search the 
World Wide Web for keywords you specify.

Hotlist button
Launches the Hotlists dialog box, allowing you to 
create and use hotlists, lists of Web pages you 
organize by subject.

Backward button
Returns to the Web page that was loaded before the 
current page.

Forward button
Moves to the Web page that you viewed after the 
current page.    This is only active if you have moved 
back to a previous page.

Reload button
Reloads the current Web page.    This may be useful 
if you have problems viewing the current screen.

Home button
Loads the startup home page.    



Stop button
Stops loading the Web page that is currently loading. 
You can click the Reload button to load the page 
again.

Mail button
Launches the SPRY Mail application, allowing you to 
send and receive mail messages.

If you don’t have SPRY Mail, you will get a dialog box
allowing you to send mail using Mosaic’s built-in mail 
feature.

News button
Allows you to access newsgroups, using Mosaic’s 
built-in news feature.

Add button
Adds the currently displayed Web page to the current
hotlist.

Web Page box
Lists the URLs of the Web pages you have recently 
accessed.    Select a URL from the list to immediately 
load that page. 

You can also type a URL in this box and press 
ENTER to access the corresponding Web page.

TIP    If you want to quickly access a URL that takes 
the form http://www.company.com, type company in
the Web Page box.

Logo
Moves to indicate that an action (such as loading a 
Web page or image, or downloading a file) is in 
progress.    

hyperlink
Jumps to another Web page.    Some hyperlinks allow
you to download a file or perform another action 
(such as sending an e-mail message).    

Hyperlinks are usually indicated by colored text, or in 
the case of images, by a colored border (the default 
color is blue).

status bar

Displays the progress of various actions.    Also 
displays the URL for any hyperlink when the cursor is



placed on that hyperlink.

Additional Glossary Items



caching
Mosaic uses caching to store retrieved information on your 
computer in order to improve performance.    When you next access 
the same information, Mosaic will access that information from the 
cache instead of from the Internet.    If you frequently access the 
same Web pages, caching will speed up access to those pages.

Mosaic uses a combination of    memory and disk caching to store 
Web page information.    Memory caching uses available RAM to 
store information and is very fast.    Disk caching creates files on 
your system (using a permanent amount of disk space); it is not as 
fast as memory caching, but is faster than retrieving a page from the
Internet.

dithering
A process Mosaic uses to reproduce the original colors of an image 
when those colors are not available on the system.    Dithering uses 
available system colors to mimic the original colors of an image, 
resulting in more accurate color and shading of images.

drag and drop
You can drag and drop a URL in the Mosaic window by placing your 
mouse cursor over it and holding down your mouse button until the 
cursor changes to a document icon:

 
You can then drag the item to its destination.    You can only drag 
items to programs that support drag and drop, such as Microsoft® 
Word for Windows™ or Windows File Manager. 

edit keys

To Press

Move one character or line arrow keys

Move one word to the left CTRL+LEFT ARROW

Move one word to the right CTRL+RIGHT ARROW

Move to the start of the line HOME

Move to the start of the 
message

CTRL+HOME

Move to the end of the line END

Move to end of message CTRL+END

Start a new paragraph ENTER

Delete the current character DEL

Delete the character to the 
left

BACKSPACE

Move right five spaces TAB

FTP site





Gopher site



hyperlink
Text or an image that jumps to another Web page.    Some 
hyperlinks allow you to download a file or perform another action 
(such as sending an e-mail message).    

Hyperlinks are usually indicated by colored text, or in the case of 
images, by a colored border (the default color is blue).

Hyperlink menu
The Hyperlink menu appears when you click the right mouse 
button on a hyperlink. The menu items will vary according to the 
type of hyperlink you have highlighted. 

MIME Type
MIME (Multipurpose Internet Mail Extensions) is a general 
purpose encoding method for exchanging multimedia data over 
the Internet.    

Items on HTML Web pages have MIME types defined for them.    
For instance, MPEG movie files have MIME type video/mpeg and 
TIFF format graphics have type application/tiff.    Mosaic uses 
MIME types to decide which program to use to display an item.

MIME types take the form type/subtype

where type is    application, audio, image, text, or video,

and subtype is the actual file type (such as zip, mpeg, rtf).

MIME types are defined by the author of a Web page; there are 
MIME types currently in use for almost every type of file.

newsgroup



Quick menu
The Quick menu appears when you click the right mouse button on 
an unused area of the Mosaic window.

startup home page
A Web page that will be opened automatically when you start 
Mosaic, and when you click the Home button on the Mosaic 
toolbar.

You can specify the startup home page by typing the URL for that 
page in the Pages tab in the View Options dialog box.

Menu popups



Open

Opens the selected item.

Save To Disk

Saves the selected item to disk.

Get Information

Displays information about the selected item, such as MIME type, 
size, and pathname.

Copy URL

Copies the selected item’s URL to the Windows clipboard. This is 
useful for pasting a URL into a mail message, for example.

Load Image

Opens the selected image in an external program.

Save Image To Disk

Saves the selected image to disk.

Get Image Information

Displays information about the selected image, such as image 
type, size, and pathname.

Copy Image URL

Copies the selected image’s URL to the Windows clipboard.

Create Shortcut

Creates a Windows 95 shortcut for the currently selected URL (or 
current Web page, if no URL is selected).    This option is only 
available in Windows 95.

Back

Returns to the Web page that was loaded before the current 
page. This is the same as clicking Backward on the toolbar.

Forward

Moves to the Web page that you viewed after the current page. 
This is only active if you have moved back to a previous page. 
This is the same as clicking Forward on the Toolbar.

Add to Hotlist
Adds the currently displayed Web Page to your current Mosaic 



hotlist.    This is the same as clicking Add Web Page to Hotlist on 
the Navigate menu.

Copy URL
Copies the URL of the currently displayed Web page to the Windows 
clipboard.

Not used

Type Subtype Description

application /commonground Common Ground files

application /iges IGES files

application /mathematica Mathematica files

application /msword Microsoft Word files

application /pdf Adobe Acrobat files

application /postscript Adobe Postscript files

application /rtf Rich Text Format files

application /wordperfect5.1 Word Perfect 5.1 files

application /zip ZIP (compressed) files

audio /aiff Audio Image File Format
audio files

audio /basic Sun/DEC/NeXT audio 
(*.AU) files

audio /wav Microsoft Windows 
WAVE (RIFF) audio files

audio /x-midi MIDI audio files

image /gif CompuServe GIF 
images

image /jpeg JPEG compressed 
images

image /targa AT&T Targa images

image /tiff Tagged Image File 
images

image /x-win-bmp Microsoft Windows 
Bitmap images

text /html HTML formatted text 
files

text /plain Plain ASCII text files

text /richtext Richtext text files

video /mpeg MPEG movie files

video /msvideo Microsoft Video (.AVI) 
files

video /quicktime Apple Quicktime movie 
files



 



Reference Contents

The menu items in SPRY Mosaic are listed below.    Click on a menu folder to see the menu items in that menu, 
and click the menu item to view help for that item.

 File menu
 Edit menu
 View menu
 Navigate menu
 Tools menu



Reference Contents

The menu items in SPRY Mosaic are listed below.    Click on a menu folder to see the menu items in that menu, 
and click the menu item to view help for that item.

 File menu
Open

Open Local File

Hotlists

Print

Print Preview

Print Margins

Web Page Source

Exit

 Edit menu
 View menu
 Navigate menu
 Tools menu



Open Web Page

Accesses a Web page.    This is most commonly an HTTP site, but might also be an FTP or Gopher site, a 
USENET newsgroup, or another type of resource (like a Telnet site).

The most common URL you will specify is the URL for a Web page. This is always preceded by http:// and is 
followed by the address and pathname of the Web page.

For example:

http://www.bakerstreet.com/221B.html

See Also

Understanding URLs



Open Local File

Loads the specified HTML file from your computer system into Mosaic.    Specify the name and location of the file 
you want to open.

You might use this command to open Web pages that you have saved to your system.    

See Also

Saving Web pages, files, and images 



Hotlists

Opens the Hotlists dialog box, which allows you to organize and access Web pages.    To see the items within a 
hotlist or folder, expand that hotlist or folder by double-clicking it in the Hotlists dialog box.

Open/New Opens a hotlist on your PC or creates a new one.

Add Adds a Web page or folder to the currently selected hotlist.

Insert Inserts a Web page or folder directly above the currently selected hotlist or hotlist item.

Remove Removes the selected hotlist from the Hotlists dialog box.    You will also have the 
option to delete the hotlist file from your PC.

Edit Edits the name of the currently selected hotlist or folder, or the Title or URL of the 
currently selected Web page.

Export Exports the currently selected hotlist as an HTML file.

Add to Menu Adds the specified hotlist to the Mosaic menu bar.



Print

Controls how the current Web page is printed.

Printer Displays the name of the active printer and the printer connection.

Print Range Specifies which pages will be printed.

Print Quality Selects the Print Quality used to print the document. This will vary depending on your 
printer. Usually, the displayed option should not be changed.

Copies Specifies the number of copies you want to print.

Collate Copies Organizes pages when you print multiple copies. If you select this option, a complete 
copy of the first document will be printed before the second copy is printed.

Setup Changes the current printer and connection settings. See your Windows or printer 
documentation for more information about this dialog box.



Print Preview

Displays an on-screen sample of how the printed page will appear. 

Print Opens the Print dialog box so that you can print the document.

Next Page Advances you to the next page in the document.

Previous Page Returns you to the previous page in the document.

Two Page Displays two pages of the document in the Print Preview window.

Zoom In Increases the magnification of the print preview.

Zoom Out Decreases the magnification of the print preview.

Close Closes the Print Preview window.



Print Margins

Specifies the margins to use when printing a document; by default, no margins are used when printing.

Left Margin Specifies how far from the left edge of the paper the printed page should begin.

Right Margin Specifies how far from the right edge of the paper the printed page should begin.

Top Margin Specifies how far from the top edge of the paper the printed page should begin.

Bottom Margin Specifies how far from the bottom edge of the paper the printed page should begin.



Web Page Source

Displays the HTML source code for the current Web page.    This may be useful if you are learning about HTML 
and want to see how the current Web page was written.    

You can also copy text from the Web page by using this command.

NOTE This command can only display the first 32K of an HTML file. To view the entire file when working with 
longer HTML documents, save the file to your local drive and view it with a text or HTML editor.

The menu options in this dialog box are described below.

File menu
Save As Opens a dialog box that allows you to save the displayed HTML source code to a file.

Exit Exits the Web Page Source dialog box.

Edit menu
Copy Copies any currently selected text to the Windows clipboard.

Select All Selects all the text in the Web Page Source window.



Exit

Closes the SPRY Mosaic program.



Reference Contents

The menu items in SPRY Mosaic are listed below.    Click on a menu folder to see the menu items in that menu, 
and click the menu item to view help for that item.

 File menu
 Edit menu

Copy

Paste

Find

Search Internet

 View menu
 Navigate menu
 Tools menu



Copy

Copies the currently selected text to the Windows clipboard.    This command will only be active when text is 
selected.

You may want to use this command to copy a URL from the Web Page bar so you can mail it to another person.

TIP This command cannot be used to copy text from the current Web page.    You can, however, view the Web
page source by clicking the Web Page Source command on the File menu, and using the Copy command
in that window.



Paste

Pastes the information in the Windows clipboard at the current cursor position.    This command will only be active 
if there is text in the Windows clipboard.



Find

Searches the current Web page for the text you specify.

Find What Specifies the exact text you want to locate.

Find Next Searches for the next occurrence of the text specified in the Find What box.

Match Case Finds only those occurrences with the exact combination of upper and lowercase 
letters specified in the Find box.



Search Internet

Loads a Web page designed to let you search the World Wide Web for keywords you specify.    By default, the 
Internet Wizard is launched; you can specify which Web page you want to use by changing the Search Page 
option in the Pages tab of the View Options dialog box.



Reference Contents

The menu items in SPRY Mosaic are listed below.    Click on a menu folder to see the menu items in that menu, 
and click the menu item to view help for that item.

 File menu
 Edit menu
 View menu

Toolbar

Web Page Bar

Load to Disk Mode

Auto Load Images

Kiosk Mode

Options

 Navigate menu
 Tools menu



Toolbar

Displays the Mosaic toolbar, found beneath the Mosaic menu bar.    The toolbar contains buttons that act as 
shortcuts to frequently used Mosaic features.



Web Page Bar

Displays the Web Page box, which displays a list of Web Pages Mosaic has recently displayed.    You can also 
type a URL in this box to quickly connect to a Web page.

TIP    If you want to quickly access a URL that takes the form http://www.company.com, type company in the Web
Page box.



Load to Disk Mode

Saves a Web page to your system every time you click a hyperlink, or try to connect to a page using a URL.

A dialog box will appear, prompting you for a name and location for the file. Note that the Web page will not be 
loaded and displayed on-screen; it will only be saved. To view a Web page on-screen again, turn off Load to Disk 
Mode by selecting it again in the Options menu.



Auto Load Images

Loads Web page images automatically. Turning off this command replaces all images on a Web page with graphic 
placeholders. You can load each graphic individually by clicking the image with the right mouse button and 
choosing the Load Image option from the Hyperlink menu that appears.

You may want to disable this feature if you’re connecting to the Internet over a modem, since large graphic images
take time to load.



Kiosk Mode

Displays or hides Mosaic’s menu and toolbar so that you can view Web pages full screen. To enter and exit Kiosk 
Mode, press CTRL+K.    You can also press ESC to exit Kiosk Mode.



View Options

Configures options that affect your Mosaic session, such as the toolbar style, hyperlink color, image loading, fonts,
and home page.    The View Options dialog box has three separate areas, or tabs.    Click on an item below for 
information.

Display tab (View Options)

Fonts tab (View Options)

Pages tab (View Options)



Display tab (View Options)

The options in this dialog box are described below.

Toolbar Style Specifies how to display the current toolbar.

Text Only displays a text label for each toolbar button.

Pictures Only displays a picture (no text)

Both displays a picture and text.

Hyperlinks Specifies color and underlining for Mosaic hyperlinks.

Link Color specifies the color for hyperlinks.    Clicking this option allows you to 
specify standard or custom colors.

Visited Link Color specifies the color to use for hyperlinks you have already clicked 
on.    These hyperlinks will remain this color until the period specified using the Links 
Expire option.

Links Expire specifies the period after which visited links should no longer display 
with the visited link color.

Underline Hyperlinks displays text hyperlinks as underlined text.

Main Window Specifies options that control the Mosaic window.

Save Last Window Position restores the window size and position used in the last 
Mosaic session.

Number of Web Pages in Dropdown specifies how many Web Pages are listed on 
the Web Page box beneath the Mosaic toolbar.

Images Specifies options for displaying images.

Automatically Load Images loads Web page images automatically. Clearing this box 
replaces images with graphic placeholders.

Image Update Frequency determines how often the Web page display is updated 
while loading graphic images.

By default, the screen is redrawn every 1.5 seconds.    If you are operating over a slow
modem connection, you should increase this option to a larger number (5 seconds, for
instance) so that images are loaded in before the screen is redrawn.

Image Display options specify whether dithering is used to display images. Choose 
Best Quality to use dithering; this results in the highest quality images, but will 
increase the time to display an image. Choose Fastest Speed to disable dithering and
get the fastest display performance.



Fonts tab (View Options)

Configures the appearance of text on a Web page. Text elements on a Web page have different styles associated 
with them (defined by the Web page author).    You can change the way those styles are displayed using the 
options in this dialog box.

As you change options, the sample text shown on the right will change accordingly.

Styles Specifies the Mosaic style to be modified.

Change Font Allows you to select the font type and size for the style you selected.

Enlarge All Increases the font size for all styles.

Reduce All Decreases the font size for all styles.



Pages tab (View Options)

The options in this dialog box are described below.

Home Page URL Identifies the Web page that will be loaded at Mosaic startup and when you click the 
Home button on the Mosaic toolbar.

Load Automatically
at Startup Specifies whether Mosaic connects to the specified Web Page URL when Mosaic is 

started.

Search Page URL Identifies the Web page that will be loaded when you click the Search button on the 
Toolbar or click Search Internet on the Edit menu.



Reference Contents

The menu items in SPRY Mosaic are listed below.    Click on a menu folder to see the menu items in that menu, 
and click the menu item to view help for that item.

 File menu
 Edit menu
 View menu
 Navigate menu

Backward

Forward

Reload

Home

History

Stop Transfer

Add Web Page to Hotlist

 Tools menu



Backward

Returns to the previous Web page.



Forward

Moves to the next Web page.    This option is available only if you clicked Back in the Navigate menu or the Back 
button on the toolbar to view the current page.



Reload

Reloads the current Web page.    This may be useful if you have problems viewing the current screen.



Home

Loads the startup home page, which is specified using the Pages tab in the View Options dialog box.



History

Displays a list of the Web pages you’ve accessed during the current session. 



Stop Transfer

Stops the current function. This option is most useful when you want to stop loading a Web page or image.



Add Web Page to Hotlist

Inserts the current Web Page URL and title information at the end of the current hotlist.



Reference Contents

The menu items in SPRY Mosaic are listed below.    Click on a menu folder to see the menu items in that menu, 
and click the menu item to view help for that item.

 File menu
 Edit menu
 View menu
 Navigate menu
 Tools menu

Mail

News

Import NCSA Menu as Hotlist

Options



Mail
Launches the SPRY Mail application, allowing you to send and receive mail messages.

If you don’t have SPRY Mail, you will get a dialog box allowing you to send mail using Mosaic’s built-in mail 
feature.



News
Allows you to access newsgroups, using Mosaic’s built-in news feature.



Import NCSA Menu as Hotlist

Converts an existing NCSA Mosaic menu into a Mosaic hotlist.    NCSA menus are stored in the NCSA Mosaic .INI 
file.    Note that there can be several menus in the INI file.

INI File Containing
Menu Specifies the filename and location of the NCSA Mosaic INI file from which you want to

import menus.

Browse Allows you to locate the NCSA Mosaic INI file.

Open Opens the INI file specified in the INI File Containing Menu option and displays the 
menus in that file in the Select Menu To Import box.

Hotlist File To Create Specifies the filename and location of the Mosaic hotlist you want to create.

Select Menu To 
Import Lists the NCSA Mosaic menus in the INI file you specified.    Select the menu you want

to convert to a hotlist.



Tools Options

Configures tools used by Mosaic, such as e-mail and news options, terminal programs, and proxy servers.    The 
Tools Options dialog box has three separate areas, or tabs.    Click on an item below to get help on information in 
that tab.

Services tab (Tools Options) 

File Types tab (Tools Options) 

Proxies tab (Tools Options) 

Advanced tab (Tools Options) 



Services tab (Tools Options)

Configures mail and news options, and allows you to configure terminal programs.

Mail and News
E-mail address Specifies the return address that Mosaic will add to e-mail messages when sending 

mail using the built-in mail feature.

SMTP Server Specifies the IP address of the mail server used by Mosaic when sending mail using 
the built-in mail feature.

News Server Specifies the IP address of the machine you connect to in order to read Internet news 
when using Mosaic’s built-in news feature.

Use Built-in 
Mail and News Uses Mosaic’s built-in news and e-mail tools to read and post USENET news articles 

and send e-mail messages.    If this box is cleared, Mosaic will automatically open 
SPRY Mail or SPRY News whenever e-mail or news requests are made.

Extended News 
Listing Displays a brief description for each newsgroup listed in Mosaic.    Clearing this box 

will disable these descriptions and turn off news threading.

Terminal Programs
Telnet Specifies the program to use for Telnet.

Remote Login Specifies the program to use for Remote Login (Rlogin).

TN3270 Specifies the program to use for TN3270.

Browse Allows you to search your system for a program to use for Telnet, Remote Login, or 
TN3270.

See Also

Setting up terminal programs 



File Types tab (Tools Options)

Specifies which programs are used by Mosaic to view items encountered on the World Wide Web.

For more information about defining file types, click Setting up file types .

MIME Type Indicates the MIME type of an item found on the Web; for example, audio/wav or 
video/quicktime. You must select a MIME type in this box in order to set up a program.

Extensions Indicates the file extension that should be associated with the specified MIME type.    
This item is optional, since extensions are only used when trying to open files on FTP 
servers.    Sample extensions are .wave, .wav, or .WAV for files of type audio/wav.    
(You may want to add both upper and lower cases for the extension, since many files 
are found on Unix file systems, and have case sensitive filenames)

Program Specifies the program to use to display a file with the above MIME type and/or 
extensions.

New Opens the New MIME Type dialog box, allowing you to add a new MIME type to the 
Type box, above.

Delete Removes a MIME type from the MIME Type box.

Browse Allows you to search your system for a program.    

See Also

Setting up file types 
Setting up MIME types 



Proxies tab (Tools Options)

Configures proxy servers in Mosaic.    For more information on proxy servers, click Overview of proxy servers.

Specify the IP address for each proxy server you set up.

FTP Proxy Accesses FTP sites.

HTTP Proxy Accesses HTTP sites.

SHTTP Proxy Accesses S-HTTP sites.

News Proxy Accesses news servers.

WAIS Proxy Accesses WAIS servers.

Gopher Proxy Accesses Gopher servers.

Port Specifies the port required to access the associated proxy server.    This item is 
optional.

Exclude domains Specifies domains you can access without using the related proxy (for instance, if you 
are accessing information from your own network, you will not need to go through a 
proxy server to retrieve the information).    You can specify multiple domains, 
separating them by commas.



Advanced tab (Tools Options)

Configures advanced options in Mosaic.    Be aware that changing some of these options may adversely affect 
your system performance; do not change these options without being aware of the possible effects.

Use HTTP 0.9 Displays Web pages created in the earlier HTTP/0.9 format. In most cases, hyperlinks 
to such Web pages will warn you that HTTP/0.9 is required to read them.

Change this option only if you will be accessing an HTTP/0.9 page.

Cache Specifies caching options.

 Maximum Memory Usage specifies the amount of system memory that will be used 
to cache information you access on the World Wide Web.    You might increase this 
setting if you have a lot of available system memory.

Maximum Disk Usage specifies the maximum amount of disk space that will be used 
for disk caching.    If you have a lot of free disk space available and want to improve 
performance, you might increase this setting. Once the cache is full, older items in the 
cache will be discarded as you access new Web pages.    You can use the Empty 
Disk Cache button at any time to empty the cache and recover disk space.

Files created by disk caching are stored in the \...\CACHE directory on the drive where
you installed Mosaic.

Use 8-bit Sound Configures Mosaic’s internal sound support for 8-bit (lower quality) sound cards.



Dialog Boxes



Open/Create New Hotlist

Opens a hotlist on your PC or creates a new hotlist. You will be prompted for a filename and location for the hotlist;
by default, hotlists are stored in the \DATA directory.    The extension .HOT is suggested.

If you specify an unused name, a new, empty hotlist will be created.



Name The Hotlist

Titles a hotlist you have created. This name will appear in the Hotlists dialog box.

Use a descriptive name for your hotlist, but, if you want to place the hotlist in the menu bar, keep the name short.



Add New

Specifies whether to add a new Web page or hotlist folder to the hotlist.

Web Page Adds a new Web page to the hotlist.

Folder Adds a new folder to the hotlist.

NOTE To add a Web page or folder to the middle of a hotlist, click the Insert button in the Hotlists dialog box.



Add Web Page

Adds a Web page to the current hotlist.    You must provide title and URL information as described below.

If you are viewing a Web page, this dialog box will contain the title and URL of that page.

Title Specifies a title for the Web page you wish to add to the hotlist.

URL Specifies the URL of the Web page you wish to add to the hotlist (if it is not already 
provided). Be sure that you have specified the URL correctly, or Mosaic will not be 
able to access the Web page.

See Also

Adding a Web page to a hotlist 



Add Folder

Adds a folder to the current hotlist. Give the folder a short, descriptive name that you will easily recognize.

See Also

Adding folders to a hotlist



Insert New

Specifies whether to insert a new Web page or hotlist folder into the current hotlist.

Web Page Inserts a new Web page into the hotlist.

Folder Inserts a new folder into the hotlist.

NOTE If there are no selected items in the current hotlist, this option will insert the new Web page or folder at the
bottom of the hotlist.



Insert Web Page

Inserts a Web page into the current hotlist, above the currently selected item.

If you are viewing a Web page, this dialog box will contain the title and URL of that page.

Title Specifies a title for the Web page you wish to add to the hotlist.

URL Specifies the URL of the Web page you wish to add to the hotlist (if it is not already 
provided). Be sure that you have specified the URL correctly, or Mosaic will not be 
able to access the Web page.

See Also

Adding a Web page to a hotlist 



Insert Folder

Inserts a folder into the current hotlist, above the currently selected item.    Give the folder a short, descriptive 
name that you will easily recognize.

See Also

Adding folders to a hotlist



Edit Item

Edits the title or URL of the Web page you have selected.



Edit Hotlist Title

Edits the name of the hotlist or folder you have selected.



Export Hotlist to HTML File

Exports your hotlist as an HTML file. Your exported hotlist will look much like an outline, with folders, subfolders, 
and Web page links making up the various levels of the page.

Specify a name and location for the HTML file.

File Name Specifies the filename for the HTML file. You can type a new name for the file, or 
select an existing name from the list. A filename can contain up to eight characters, 
plus a three-letter extension. The extension .HTM is suggested.

Directories Specifies the directory where you want to store the file.

Drives Specifies the drive where you want to store the file.



New MIME Type

Adds a new MIME type to the MIME type list in the File Types tab of the Tools Options dialog.    Specify a name for
the new MIME type.

See Also

Setting up MIME types 



Newsgroup Name

Connects to the newsgroup you specify.    You do not need to specify the full URL, only the newsgroup name (for 
example, alt.culture.oz).    

You must have a News Server defined in the Services tab of the Tools Options dialog box in order to access 
newsgroups.



Post News

Sends, or posts, a news article to a USENET newsgroup from Mosaic.    For more information on using news in 
Mosaic, click Posting news.

Sender Specifies your e-mail address.    This box will automatically be filled out with the e-mail 
address specified in the E-Mail Address option in the Services tab of the Tools 
Options dialog box.    If this value is incorrect, you should change it; otherwise no one 
will be able to reply to your news posting.

You can, if you wish, specify a nickname that will be displayed along with your e-mail 
address, using the following formats:

rapunzel@castle.com (Rap), “Rap” rapunzel@castle.com, or Rap 
<rapunzel@castle.com>, where rapunzel@castle.com is your e-mail address and Rap
is your nickname.

Newsgroup Specifies the name of the newsgroup where this article will be posted.    You can add 
several newsgroups to this box, if you want, separating them with commas.

Subject Specifies the subject of your news article.    Although this box is optional, it is strongly 
suggested that you provide a subject for your article.

Keywords Specifies the keywords that will appear in the header of the news posting; these 
keywords are used by some news reader programs to perform searches.    Separate 
keywords with commas.    Examples: politics, simpsons, jobs, northwest.

Content-type The MIME type of the article you send.    Currently, only text files are supported; 
text/plain is selected by default.    You typically will not need to change this option.

Enter the message 
body Type the message body in the space provided.    All standard Windows edit keys are 

supported.    



Send Mail

Sends an e-mail message from Mosaic.    For more information on how sending e-mail works in Mosaic, click 
Sending mail.

Sender Specifies your e-mail address.    This box will automatically be filled out with the e-mail 
address specified in the E-mail Address option in the Services tab of the Tools 
Options dialog box.    If this value is incorrect, you should change it; otherwise the 
recipient will not be able to reply to your mail.

You can, if you wish, specify a nickname that will be displayed along with your e-mail 
address, using the following formats:

rapunzel@castle.com (Rap), “Rap” rapunzel@castle.com, or Rap 
<rapunzel@castle.com>, where rapunzel@castle.com is your e-mail address and Rap
is your nickname.

Recipient Specifies the recipient of the mail message.    Type a standard e-mail address, such as
lucy@narnia.com.

CC Specifies any additional recipients to whom you want to send a copy of the mail 
message.

Subject Specifies the subject of your mail message.    Although this box is optional, it is 
strongly suggested that you provide a subject for your message.

Content-type The MIME type of the message you send.    Currently, only text files are supported; 
text/plain is selected by default.    You typically will not need to change this option.

Enter the message 
body Type the message body in the space provided.    All standard Windows edit keys are 

supported.



Probably not used



Color

Sets the color of hyperlinks displayed in the Mosaic window.    You can choose from a predetermined palette of 
colors or define a custom color.

Basic Colors Displays the colors available on your system.    To use one of the displayed colors for 
hyperlinks, click on that color.

Custom Colors Displays any custom colors you have defined using the Define Custom Colors feature.
To use a custom color for hyperlinks, click on that color.

Define Custom Colors Expands the Link Color dialog box, allowing you to define a custom color.    Click on 
the displayed color grid to select the color you want to define.    You can then click on 
the slider bar to the right of the grid to adjust the lightness or darkness of the color.

Click the Add to Custom Color button to add the custom color to the Custom Colors 
list.



Font

Specifies the font, font style, and size used to display the currently selected Mosaic style.

Font Specifies a font name.    This box lists all the fonts currently available on your system.

Font Style Specifies a font style. To use the default font style for a given font, select Regular. 

Size Specifies a font size. The sizes available depend on the printer and the selected font. 
If the size you type is not available on the current printer, the closest available size will 
be chosen.

Sample Displays the effects of the formatting you specify with the options above.
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Overview of browsing Web pages

When you open a Web page in Mosaic, you will see the text on that page, and any images on that page will then 
be loaded, top to bottom.    You can control how images are loaded onto the page by changing the Images options 
in the Display tab of the View Options dialog box.

To stop loading the current page, click Stop Transfer on the Navigate menu (or click the Stop button on the 
toolbar). 

If a page does not load properlyfor instance, all of the images on the page do not appear or the connection to the 
server times outyou can click Reload on the Navigate menu (or click the Reload button on the toolbar) to try to 
load the page again.



Moving to another Web page

There are several ways to move to another Web page in Mosaic.

Click To

A hyperlink Jump to the Web page referenced by the 
hyperlink.

The Backward and Forward
buttons on the toolbar

    

Move to the Web pages you accessed 
before and after the current page.

The Home button on the 
toolbar

Access the startup home page  for 
Mosaic.

The Web Page   box  Type the URL for a Web page, or access 
a list of the Web pages you have recently
visited.

History on the Navigate 
menu

Access a list of the Web pages you have 
visited this session.

Opening a Web page using a URL

You can specify a Web page to open by supplying the URL for that page.    Most Web pages that you will 
encounter are HTML pages, which reside on HTTP sites.    This type of URL is preceded by http:// followed by the 
address and pathname of the HTML page, as in http://www.bakerstreet.com/221B.html.

To open a Web page using a URL:

1. Type a URL in the Web Page box found below the Mosaic toolbar.

2. Press ENTER.
TIP You can paste a URL that you have copied from another program into this box.    With your cursor in the 

box, press CTRL+V.

See Also

Understanding URLs



Opening a local file

You can open HTML files that are stored on your local system.    

This command lets you view a Web page without connecting to the Internet.

Local Web pages usually have a file extension of .HTM.

To open a local Web page:

1. Click Open Local File on the File menu.    

2. Locate the local Web page file.

See Also

Saving Web pages, files, and images
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Copying and pasting information

Like other Windows programs, Mosaic includes full support for the Windows clipboard.    This allows you to paste 
information from another program into Mosaic, or copy information from Mosaic to other programs.    For example, 
you might want to copy a URL from a mail message or news article and paste it into the Web Page box in order to 
quickly access that URL.

NOTE You can only copy and paste in areas in Mosaic where you can also type.

To Do this

Copy information from 
Mosaic

Select the information, and press CTRL+C.

Copy a URL from a Web 
page

Move your cursor over the URLs hyperlink, 
click the right mouse button, and click Copy 
URL from the Hyperlink menu.

Paste information into 
Mosaic

Place your cursor at the location where you 
want to paste the information, and press 
CTRL+V.

Saving Web pages, files, and images

There are several different ways to save items in Mosaic:

Use Mosaics Hyperlink menu.

Click a hyperlink for an item you want to save with the right mouse button and select either Save to Disk 
or Save Image to Disk from the Hyperlink menu.

Use Load to Disk mode.

You can turn on Load to Disk mode to save each graphic or hyperlink that you click on, without loading it.  
Click Load to Disk Mode on the View menu (a check mark will indicate that the mode is enabled).    When 
Load to Disk Mode is enabled, each time you try to access an item you will be prompted for a name and 
location to save the item.    Note that items that you access will not be loaded or displayed; they will only 
be saved.    Mosaic will continue to try to save items until you disable Load to Disk Mode by selecting the 
Load to Disk Mode option again.    If you want to use Load to Disk Mode selectively, you can temporarily 
enable it by holding down the SHIFT key while you click an item.

See Also

Opening a local file



Printing a Web page

You can print the Web page you are viewing to a printer.    If you want to see how the output will look when you 
print, click Print Preview on the File menu.

To print a Web page:

Click Print on the File menu.    You can click the Setup button in the Print dialog box to specify a different 
printer or set up options for printing.

To change the print margins:

Click Print Margins on the File menu to adjust the margins of the printed document.
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Overview of hotlists

You can store your favorite Web pages in a hotlist so that you can easily access those pages again.    You might 
use hotlists to group Web pages by category, such as subject (Games, Sports, Weather, Work) or user (Joes 
hotlist, Ryans hotlist, Gregs hotlist).    Individual hotlists can contain folders and subfolders to further organize your 
information.

Hotlists are stored in hotlist files (usually with the extension .HOT), which makes it easy for you to give hotlists to 
other SPRY Mosaic users.

You can access hotlists from the Hotlists dialog box, or add them to Mosaics menu bar for quick access.



Accessing a Web page using a hotlist

You can use a hotlist to quickly access your favorite Web pages.    Mosaic includes a few predefined hotlists to get 
you started.

To access a Web page using a hotlist:

1. Click Hotlists on the File menu.    The Hotlists dialog box will appear, displaying the predefined hotlists 
included with Mosaic.    A hotlist is displayed using the following icon:

 

2. Open the hotlist that contains the page you want to access by double-clicking the hotlist icon.    You can 
double-click a folder icon in the hotlist to see the items in that folder.

3. Double-click the Web page you want to display.

See Also

Creating a new hotlist
Opening a hotlist
Adding a Web page to a hotlist
Adding folders to a hotlist



Creating a new hotlist

You can create a new hotlist so that you can organize your favorite Web page addresses for fast access.

To create a new hotlist:

1. Click Hotlists on the File menu.    The Hotlists dialog box will appear, displaying any hotlists you have 
already created.

2. Click the Open/New button.
3. Specify a filename and directory for your new hotlist (the extension .HOT is suggested).
4. Type a name for the hotlist.    The name can be any length you want, but you may want to keep it short in 
case you add the hotlist to Mosaics menu bar.

TIP If you use NCSA Mosaic, you can convert your custom menus to hotlists using the Import NCSA Menu as 
Hotlist command on the Options menu.

See Also

Adding a Web page to a hotlist
Adding folders to a hotlist
Adding a hotlist to the Mosaic menu



Opening a hotlist

You can open an existing hotlist file and add it to the Hotlists dialog box.    This is useful if you receive a hotlist from
someone else and want to add it to Mosaic, or want to add a hotlist that you previously removed from the Hotlists 
dialog box.

To open a hotlist:

1. Click Hotlists on the File menu.

2. Click the Open/New button. The Open/Create New Hotlist dialog box will appear.
3. Specify the hotlist file name.



Adding a hotlist to the Mosaic menu

You can use any hotlist as a Mosaic menu, with all the hotlist items appearing as items on the menu.    Folders 
within the hotlist will appear as menu items, and the folder contents will appear as sub-menu items.    

To add a hotlist to the Mosaic menu:

1. Click Hotlists on the File menu.

2. Select the hotlist you want to add to the Mosaic menu.
3. Check the Use Hotlist as menu item box.    The hotlist icon will change to the following icon:

and the hotlist will be added to the menu.



Adding a Web page to a hotlist

You can easily add a Web page to one of your hotlists.

To add a Web page to the end of the hotlist:

If you are currently viewing the Web page you want to add to a hotlist, you can click Add Web Page to Hotlist
on the Navigate menu to add the document to the end of the current hotlist (the last hotlist you opened). 

To add a Web page to a hotlist:

1. Click Hotlists on the File menu.

2. Select the hotlist to which you want to add the Web page.    
3. Select the place in the hotlist where you want to place the page.    The new Web page will be added above 
the item you select.

For instance, to insert the Web page Cooking with Oregano in between Badminton tips and Wide World of
Webcrawling, you would highlight Wide World of Webcrawling before inserting the new Web page.

4. Click the Insert button.

5. Click Web Page in the Insert New dialog box.

6. Fill out the next dialog box with information about the Web page.    If you are currently viewing a Web page, 
this dialog box will be filled out for you.

In the Title box, type the name you would like to use for this Web page in your hotlist.    Spaces are 
permitted.

In the URL box, type the URL for the Web page.    You can copy and paste a URL into this dialog box, if 
you choose.

TIP You can also drag and drop a hyperlink into a hotlist or hotlist folder.



Adding folders to a hotlist

You may want to use hotlist folders to help organize your information.    You can place a folder anywhere in a 
hotlist, even inside another folder. 

To add a folder to a hotlist:

1. Select the hotlist to which you want to add the folder.

2. Select the place in the hotlist where you want to add the folder.    The new folder will be added above the 
item you select.

For instance, to insert a Humor folder between a Hobbies folder and a Lists of Sites folder, you would 
highlight Lists of Sites before inserting the new Web folder.

3. Click the Insert button.

4. Click Folder in the Insert New dialog box.    

5. Specify a name for the new folder.



Exporting a hotlist

You can export any of your hotlists as an HTML file.    You might do this to give the hotlist information to someone 
who doesnt have SPRY Mosaic.    You can also use the hotlist as your default home page.

To export a hotlist:

1. Click Hotlists on the File menu.

2. Click the Export button.
3. Type a filename for the hotlist; the extension .HTM is suggested.

After you export the file, you can open it by clicking Open Local File  on the File menu.    The file will be displayed 
as a Web page containing a list of hyperlinks that jump to the Web pages in your hotlist.
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Searching the World Wide Web

The default Mosaic hotlists and startup home page contain many useful links that will help you get started using 
the World Wide Web.

You can click the Search button on the toolbar, or click Search Internet on the Edit menu to quickly launch a Web 
page you can use to search the World Wide Web.    By default, this page is the Internet Wizard, an easy-to-use 
search tool that uses keywords to search for information.    You can change the Search page that is loaded by 
changing the Search Page option in the Pages tab of the View Options dialog box.

There are many Web pages on the Internet that allow you to search for specific information or browse indexed lists
of information.    Some popular and useful sites are listed below.

Site URL (address)

World Wide Web Worm 
(search tool)

http://www.cs.colorado.edu/home/mcbryan/WWWW.html

Yahoo (list & search tool) http://www.yahoo.com

WWW Virtual Library (list) http://www.w3.org/hypertext/DataSources/bySubject/Overview.html

Web Servers (list) http://www.w3.org/hypertext/DataSources/WWW/Servers.html

GNN (list) http://gnn.com/gnn/gnn.html

See Also

Opening a Web page using a URL 



Finding text on a Web page

You can search a Web page for particular text.

To find text on a Web page:

1. Click Find on the Edit menu.

2. Type the text you want to search for in the Find What: box.    If you wish to search only for words that match 
the capitalization of the specified text, check the Match Case button.
3. Click the Find Next button.

The search will occur from the top of the current screen to the bottom. If the search word is found, the line
of text containing the word will appear at the top of the page.

4. Click the Find Next button to find the next occurrence of the word.

-OR-

Click Cancel to close the dialog box
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Overview of FTP, Gopher, News, and Mail

Mosaic not only lets you view HTML pages specifically designed for the World Wide Web, but allows you to access
other Internet resources such as FTP and Gopher sites.    You can also use Mosaic to access USENET news and 
send e-mail.    Note that Mosaic is primarily designed for browsing the World Wide Web; for more full-featured use 
of FTP, Gopher, News, and Mail, more sophisticated programs may be preferred.

Click one of the items below for specific information. 

 FTP
 Gopher
 News
 Mail



FTP Overview
FTP is used to send and receive files across networks.    Anonymous FTP sites on the Internet contain 
countless freeware and shareware files that you can transfer to your PC.    

Due to the popularity of ftp sites, there may be restrictions, such as limited hours for ftp access or limits to 
the number of users that can access a site at once.

Gopher Overview
Gopher sites display collections of information organized by subject.    You can access many different 
types of resources using Gopher, including images, sounds, and searchable databases.

You may need additional programs to view some of the items you find using Gopher.

News Overview
USENET news is a forum for discussion (similar to a bulletin board system, but on a much larger scale) 
that is found on the Internet.    You can read news articles about specific topics and contribute to the 
discussions by posting (adding) your own articles.

Mosaic allows you to access news using Mosaics built-in news function or the SPRY News program.    If 
you have SPRY News on your system, Mosaic will automatically launch it when you access a newsgroup 
or news article.    If you do not have SPRY News, or if you would prefer to use SPRY Mosaics built-in 
news function, check the Use Built-in Mail/News box in the Services tab of the Tools Options dialog box.

In order to read News using Mosaic, you will need to have access to a News Server.    You can set up the 
news server address in Mosaic by typing it in the News Server box in the Services tab of the Tools 
Options dialog box.

Mail Overview
Mosaic can be used to send e-mail messages; for example, some hyperlinks contain an e-mail address, 
designed for sending comments to the Web page author.    However, Mosaic cannot receive mail.    If you 
want to receive mail, you will need a dedicated mail program such as SPRY Mail and an account on a 
mail server.

Mosaic allows you to send mail using either Mosaics built-in mail function or the SPRY Mail program.    If 
you have SPRY Mail on your system, Mosaic will automatically launch SPRY Mail whenever you try to 
send a mail message.    If you do not have SPRY Mail, or if you would prefer to use SPRY Mosaics built-in
mail function, you should check the Use Built-in Mail/News box in the Services tab of the Tools Options 
dialog box.

In order to send mail using the built-in mail send feature, you will need to specify an SMTP Server in the 
Services tab of the Tools Options dialog box.

Accessing FTP sites

You can access FTP sites and download files using Mosaic.

To access an FTP site:

1. Place your cursor in the Web Page box beneath the toolbar. 

2. Enter the URL for the FTP site you want to connect to:

ftp://hostname where hostname is the IP address of the FTP site, for example, ftp://ftp.narnia.com, or 
ftp://165.121.6.26.



If youre connecting to an FTP site which requires a username and password, you can also type 
ftp://username:password@hostname, where username and password are your username and 
password on the ftp site, for example, ftp://lucy:aslan@ftp.narnia.com.

The FTP Site will be displayed as a list of folders and files.    You can double-click a folder to open it and 
display its contents.    A hyperlink at the top of the file (usually called Up to Parent Directory) will take you 
back to the previous level.

To download a file:

When you see a file you want to access, click the filename.    Text files will automatically be displayed in the 
Mosaic window.    If you set up a program for the file (using the File Types option), the file will be opened using the 
program.    Otherwise, you will be asked if you want to save the file to disk.

See Also

Setting up file types



Accessing Gopher sites

You can access a Gopher site using Mosaic.

To access a Gopher site:

1. Place your cursor in the Web Page box beneath the toolbar.

2. Enter the URL for the Gopher site you want to connect to: 

gopher://hostname where hostname is the IP address of the Gopher site, for example, 
gopher://gopher.narnia.com, or gopher://165.121.6.45.

The Gopher site will appear as a list of different types of    items.

To access a Gopher item:

When you see an item you want to access, double-click it.    If the item is a text file, Mosaic will display it in 
the Mosaic window.    If the item is a Telnet, TN3270, or Rlogin site, Mosaic will open it using the tool set up in the 
Services tab of the Tools Options dialog box.    If the item is a search tool, Mosaic will allow you to search the 
indicated database.

For other items, if you have set up a program for that file (using file types), the file will be opened using 
that program.    Otherwise, you will be asked if you want to save the file to disk.

See Also

Setting up file types



Reading news

You can read news on a News Server using Mosaic.    You may find links to newsgroups on the World Wide Web, 
or you may want to connect to a newsgroup directly, as described below.

To access news:

1. Click on a hyperlink that points to a newsgroup or news article

-OR-

Place your cursor in the Web Page box beneath the toolbar and enter the URL, as described below:

To Type

Access a specific 
newsgroup

news:newsgroupname where newsgroupname is the 
full name of the newsgroup you want to access, for 
example, news:alt.smurfs.

List all newsgroups 
on the News Server

news:*

List a range of 
newsgroups

news:category.* where category is the part of the 
newsgroup name that you know, and * signifies all 
newsgroups within that category.

For example, news:alt.tv.* would display alt.tv.simpsons, 
alt.tv.90210, etc., news:alt.* would display all the 
newsgroups with the prefix alt, and news:comp.* would 
display all the newsgroups with the prefix comp.

2. If you are viewing a list of newsgroups, you can double-click any newsgroup to display the articles in that 
newsgroup. A list of news articles will appear.

Mosaic displays news articles as bulleted items on the screen, grouped by threads.      Articles posted in 
response to an original article will be shown indented below that article and will be identified using the 
posters name, rather than an article subject.

NOTE By default, Mosaic displays descriptions of all the newsgroups; to disable this feature, clear the Extended
News Listing box in the Services tab of the Tools Options dialog box.    Note that unchecking this option 
will disable threading in news (described below).

3. To view an article, simply click its title in the article list.

Mosaic displays hyperlinks at the top of the screen that you can click to navigate through threads.    When 
you are viewing an article that is part of a thread, you will see either Next thread or Next article in 
thread and Previous article in thread, depending on where you are in the thread.



Posting news

You can use Mosaic to post a news article to a newsgroup, as described below.    Note that some news servers 
and newsgroups will not allow you to post articles.

To post a news article from the newsgroup screen:

1. Make sure the newsgroup you want to post to is displayed on the screen, with the articles in that 
newsgroup listed.

2. Click the Post to newsgroup hyperlink at the top of the screen, or, if you want to follow up the article 
(responding to the article thread, and including the text of the article), click the Followup to message hyperlink.
3. Fill out the Post News dialog box with information about your article.        The Sender box should be filled out 
for you.    Be sure to specify a Subject for your article and complete the Sender box.
4. Type your article in the space provided.    All the standard Windows edit keys are supported, including CTRL-
V to allow you to paste text from other programs into your article.

NOTE Mosaics News feature does not automatically wrap words down to the next line when you reach the end 
of a line.    You will need to press ENTER at the end of each line of your message so that your message 
will be displayed properly.

To post a news article using a URL:

1. Place your cursor in the Web Page box beneath the toolbar.

2. Enter the following URL:

newspost:newsgroupname{,newsgroupname,newsgroupname}{/followup} where newsgroupname 
is the name of the newsgroup you want to post to (you can specify multiple newsgroups by separating 
them by commas; do not have spaces between commas).

/followup is optional, and indicates that you want the posting to be a follow-up posting.    If an article is 
currently displayed, the followup post will contain the text of the original article.

Examples 

newspost:alt.tv.seinfeld
newspost:rec.bicycles,rec.sports.cycling
newspost:alt.suburbia/followup



Sending mail

You can send e-mail messages using Mosaic.    You may find hyperlinks that will send an e-mail message to the 
address indicated in the hyperlink text.    You can also send e-mail as indicated below.

To send mail from Mosaic:

1. Place your cursor in the Web Page box beneath the toolbar.

2. Enter the following URL
mailto:address where address is the e-mail address you want to send mail to, for example, 
mailto:lucy@narnia.com.

3. Fill out the Send Mail dialog box with information about your message.    Be sure to specify a Recipient 
and a Subject for your message.

4. Type your mail message in the space provided.    All the standard Windows edit keys are supported, 
including CTRL-V to paste text from other programs into your message.

NOTE Mosaics Mail feature does not automatically wrap words down to the next line when you reach the end of 
a line.    You will need to press ENTER at the end of each line of your message so that your message will 
be displayed properly.



Using SPRY Mosaic

The following topics provide step-by-step instructions on common tasks.

 Browsing Web pages
 Working with Mosaic information
 Working with hotlists
 Finding information
 Using FTP, Gopher, News, and Mail
 Configuring Mosaic

Improving Mosaics performance

Changing the screen appearance

Setting up file types

Setting up terminal programs

Using proxy servers



Improving Mosaics performance

There are several ways you can improve Mosaics performance.

Increase system memory.

As with any Windows program, Mosaics performance will improve if you have more available system 
memory.    If you often load in large images or download large files, you will want to optimize your memory.

Using extended (not expanded) memory and a large Windows swapfile (at least twice as large as your 
physical RAM; for example, for 4 MB RAM, have a 8MB swapfile) may improve your performance. See 
your DOS and Windows documentation for additional information on imcreasing memory.

Turn off inline images.

If you have a slow connection, or if you do not need to see images, you can turn off the display of images 
by clearing the Automatically Load Images option in the Display tab of the View Options dialog box.    If 
you turn off this option, image placeholders will load instead of the images, and Web pages will load 
substantially faster.    You can still selectively load in images by clicking the images with your right mouse 
button and selecting Load Image from the hyperlink menu.

Note that many images are used as hyperlinks to other Web pages, so disabling this option may make it 
more difficult to navigate the Web.    Many, but not all, Web pages display alternate methods for accessing
images.

Change how often Mosaic loads images.

If you have a slow Internet connection, you may want to change how often Mosaic loads images.    Mosaic
redraws the screen at the interval you specify using the Image Update Frequency in the Display tab of 
the View Options dialog box.

Change how fast Mosaic loads images.

Normally, Mosaic loads and displays images with the highest quality possible.    You can choose to have 
Mosaic load images faster, sacrificing some degree of quality, by changing the Image Display option in 
the Display tab of the View Options dialog box to be Fastest Speed.

Change the caching value.

Mosaic has a number of caching options, which can be configured using the Cache options in the 
Advanced tab of the Tools Options dialog box.

Create a local startup home page.

If your startup home page does not change often, you may want to save the page to a local HTML file, so 
that you can access it more quickly.    Then, specify the name of the local HTML file in the Pages tab of 
the View Options dialog box.



Changing the screen appearance

There are several ways to change the appearance of the Mosaic window.

Change the fonts used for text on the Mosaic window.

Text elements on a Web page have different styles associated with them (defined by the Web page 
author).    You can change the font types and sizes that are used for these styles using the Fonts tab in 
the View Options dialog box, selecting the style you want to change, and clicking the Change Font 
button.    You can also choose to enlarge or reduce all the fonts using this dialog box.    Note that changes 
in this dialog box affect all Mosaic sessions.

Change the appearance of the Mosaic hyperlinks.

You can change the color and underlining of Mosaic hyperlinks using the Link Color and Visited Link 
Color options in the Display tab in the View Options dialog box.

Change the toolbar appearance.

The toolbar style can be changed between picture and text, picture only, and text only by changing the 
Toolbar Style option in the Display tab of the View Options dialog box.

Display or hide the toolbar and Web Page bar.

You can hide the toolbar and Web Page bar (located beneath the toolbar) by unchecking Toolbar and 
Web Page Bar in the View menu.



Setting up file types

Mosaic can display text, GIF and JPEG graphics, and can play .AU and .AIFF sound files.    Other types of files, 
however, such as MPEG movie files, require you to use additional programs in order to display them.

You can specify which program Mosaic will use to open a certain type of file, as described below.

To configure a file type:

1. Click Options on the Tools menu.

2. Select the File Types tab in the Tools Options dialog box.

3. In the MIME Type box, select the MIME type of the item for which you want to set up a program.    You 
may have to set up a new MIME type, if the MIME type you want is not listed.    You should try to use the 
same MIME type that is used on the World Wide Web server you are accessing.

4. In the Extensions box, type any file extensions (such as .MPG, .AVI, or .DOC) you want to use for the 
specified MIME type.    If you are providing several extensions, separate the extensions with commas.    
Note that UNIX servers sometime have case-sensitive filenames; you may want to use both upper and 
lower cases for the extension (e.g. .mpg,.MPG,.mpeg).    

Since MIME types, not file extensions, are used when accessing items on an HTTP server, you only have 
to supply file extensions if you want to be able to access items on FTP or Gopher sites using the program 
you specify.

5. In the Program box, type the full path and filename of the program you want to use for the specified 
MIME type.    If you are not sure of the location of the program, click the Browse button.



Setting up MIME types

Mosaic uses MIME types to decide how to treat items you try to access on an HTML Web page.    For instance, 
MPEG movie files have MIME type video/mpeg, and TIFF graphics have type application/tiff.    You can find out the
MIME type of an item by clicking it with the right mouse button and choosing Get Information (or Get Image 
Information) from the Hyperlink menu that appears.    

You may need to add new MIME types in order to set up programs properly in Mosaic (using the File Types tab in 
the Tools Options dialog box).    Make sure you specify the MIME type correctly, since that is what Mosaic uses to 
recognize the item so that it can start a program.

You can add a MIME type as follows:

1. Click Options on the Tools menu.

2. Select the File Types tab in the Tools Options dialog box.
3. Click the New button.
4. Type a name for the new MIME type.
5. Click OK to add the new MIME type.    The new MIME type will be added to the Type: list, and you can now 
set up programs for that MIME type to that MIME type.

NOTE Mosaic uses extensions, not MIME types, to recognize items on FTP sites.    In order to set up file types 
for items on an FTP site, you will still need to set up a MIME type, however.    The name for this MIME 
type can be anything you like, since the MIME type is not really used by Mosaic to determine which 
program to use to open the item.      For example, if you wanted to set up a MIME type so that you could 
open Visio™ files (from Shapeware Corporation), you might create a new MIME type called application/x-
visio.    You can then set up that MIME type, specifying the file extension for Visio files (.vsd) and setting 
up Visio as the program to use.    It is conventional to name user-defined MIME types with an x-extension.



Setting up terminal programs

If you need to connect to a Telnet, TN3270, or Rlogin site, and have the appropriate programs on your system, you
can configure Mosaic to use them automatically when connecting to those sites.

To set up terminal programs:

1. Click Options on the Tools menu.

2. Select the Display tab in the Tools Options dialog box.
3. In the Terminal Programs box, fill out each of the boxes (Telnet, Remote Login, and TN3270) with the full 
pathname of the program you want to use.    If you are not sure of the exact location of a program, you can click the 
Browse button next to the program box to search for the program on your system.



Using proxy servers

Overview of proxy servers

Setting up proxy servers



Overview of proxy servers

Some networks are not directly connected to the Internet, but are protected by Internet firewallssoftware products 
designed to protect networks from outside intrusion.    If your network is behind a firewall, Mosaic will have to 
communicate with proxy servers in order to access services on the Internet.    Proxy servers forward requests for 
information to the requested server and return the information to Mosaic.

Mosaic supports proxy servers based on the ANS and CERN specifications.    Contact your network administrator 
for information on any proxy servers used in your organization.



Setting up proxy servers

You can set up proxy servers for FTP, HTTP, S-HTTP, News, WAIS, and Gopher.

To set up proxy servers:

1. Click Options on the Tools menu.

2. Select the Proxies tab in the Tools Options dialog box.
3. Specify the address for each proxy server that you will need to use.    This should be an IP address, such as 
165.121.6.6, or a fully qualified domain name, like proxy.circe.com.    Note that proxy servers are often all found on 
the same machine (with the same port).

If a specific port is also required to access a proxy server, type it in the Port box next to the server name.

4. You can exclude specific domains from proxy access using the Exclude Domain option.    Specify the 
domain names you want to exclude; if you have more than one domain name, separate the domains with 
commas.

When accessing a host on a specified domain, Mosaic will not go through a proxy server.    For instance, if
you are accessing information from your own network, you will not want to go through the proxy server to 
retrieve the information.    Also, if you have another domain within your organization that is also behind 
your Internet firewall, you may want to bypass the proxy server and communicate directly with machines 
in that domain, since security is not an issue in those cases.

Once you define a proxy server for a service, Mosaic will always use a proxy server to access that service, unless 
you are accessing a domain listed in the Exclude Domain box.




